Задать вопрос
26 апреля, 04:12

Описать функцию square (k) логического типа, возвращающую True, если целый параметр k (>0) является квадратом некоторого числа, и False в противном случае. Паскаль

+5
Ответы (1)
  1. 26 апреля, 07:53
    0
    Var k: integer;

    function square (k: integer) : boolean;

    begin

    if sqr (trunc (sqrt (k))) = k {Проверяем, является ли квадрат округлённого квадратного корня самим числом}

    then

    square : = true

    else

    square : = false; end;

    begin

    read (k) ;

    writeln (square (k)) ;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Описать функцию square (k) логического типа, возвращающую True, если целый параметр k (>0) является квадратом некоторого числа, и False в ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Выберите логическое выражение, принимающее значение True a) (True and True) and (False or False) b) Not (True and Not False) or False c) (True or False) or Not (True and True) d) Not (True or False) and True
Ответы (1)
1. Вычислите логические выражения: not true and not false not true or not false not (true or false) not (true and false) 2. Напишите условие нахождения точки a в первом квадранте системы координат, считая ее координаты заданными X переменными x, y.
Ответы (1)
Даны два числа A и B. Выведите на экран значение логического выражения, которое принимает значение true, если оба числа находятся в интервале (X, Y), и false - в противном случае
Ответы (1)
1. Выведите на экран значение логического выражения, которое принимает значение true, если К является двухзначным числом, кратным пяти и false - в противном случае.
Ответы (1)
Составить программу печатающую зн ачение true если указанное высказывание является истинным, и false - в противном случае натуральное число N является точным квадратом
Ответы (1)