Задать вопрос
6 июля, 17:06

Даны билеты с номерами от 0001 до 9999, найти кол-во счастливых билетов

+2
Ответы (1)
  1. 6 июля, 18:49
    0
    Var n, i: integer;

    begin

    n : = 0;

    for i : = 1 to 9999 do

    if i mod 10 + i div 10 mod 10 = i div 100 mod 10 + i div 1000 then

    n : = n + 1;

    writeln (n) ;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Даны билеты с номерами от 0001 до 9999, найти кол-во счастливых билетов ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Учитель проверяет работы письменного экзамена. Изначально на его столе нет ни одной работы. Иногда приносят стопку работ с подряд идущими номерами, при этом номера работ увеличиваются от низа стопки к ее верху.
Ответы (1)
поставьте знаки арифметических операций в каждой схеме. А) скорость? время=путь б) путь? время=скорость в) масса 1 батона? количество батонов=общ. масса г) кол. батонов? кол. буханок=общ. кол. д) кол. конфет в 1 коробке? кол. коробок = общ. кол.
Ответы (1)
Билеты на аттракцион имеют номера из четырёх цифр от 0000 до 9999. Назовём билет "счастливым", если сумма первых двух цифр его номера равна сумме последних двух цифр.
Ответы (1)
Составьте программу для определения суммы денег, получаемой авиакомпанией от продажи билетов на рейс из Лондона в Нью-Йорк, если в самолёте три четверти пассажиров имеют билеты первого класса, стоимостью и X рублей за каждый.
Ответы (1)
Переведите числа издвоичной системы счисления в десятичную: 1000, 0001, 0110, 0001, 0101, 0111, 0100, 1001, 0010.
Ответы (2)