Задать вопрос
30 августа, 06:00

Определить последнюю цифру заданного целого числа в pascal

+5
Ответы (1)
  1. 30 августа, 06:11
    0
    Var s, t:integer;

    begin

    write ('s=') ; readln (s) ;

    if (s>-10) and (s<10)

    then writeln ('Число однозначное')

    else begin

    t:=s mod 10;

    writeln (abs (t)) ;

    end;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Определить последнюю цифру заданного целого числа в pascal ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
1) Вычислить длину окружности и площадь круга одного и того же заданного радиуса R. Pascal (желательно с блок-схемой) 2) Найти сумму членов арифметической прогрессии, если известны её первый член, знаменатель и число членов прогрессии Pascal
Ответы (1)
Написать программу по "Из трехзначного числа Х вычли его последнюю цифру. Когда результат разделили на 10, а к частному слева приписали последнюю цифру числа Х, то получилось число 237. Найти число Х." Язык Pascal. Заранее благодарна.
Ответы (1)
Помогите написать программу на Pascal Из трехзначного числа X вычли его последнюю цифру. Когда результат разделили на 10, а к частному слева приписали последнюю цифру числа X. То получилось число N.
Ответы (1)
Как описывают переменные в Pascal? Какие стандартные числовые типы языка Pascal вам известны? Что вам известно о соответствии типов переменных в языке Pascal? Какие арифметические операции можно выполнять в Pascal?
Ответы (1)
Паскаль! Написать программу, в которой по последней цифре числа определить последнюю цифру его квадрата и последнюю цифру его куба. Для определения последней цифры числа применить операцию MOD (получение остатка от деления).
Ответы (1)