Задать вопрос
18 июня, 08:01

Составить программу с постусловием для нахождения произведения чисел от 1 до 15, имеющий в остатке от деления на 3 число 2. как я поняла, это числа 2,5,8,11 и 14 составить программу не могу. Прошу! от этого задания зависит моя четвертная оценка!

+1
Ответы (1)
  1. 18 июня, 10:19
    0
    Написал на Паскале

    uses crt;

    var

    i, n:integer;

    begin

    i:=0;

    n:=1;

    Repeat

    if i mod 3=2 then

    begin

    n:=n*i;

    end;

    i:=i+1;

    Until i>15;

    writeln (n) ;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Составить программу с постусловием для нахождения произведения чисел от 1 до 15, имеющий в остатке от деления на 3 число 2. как я поняла, ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
1. Составить программу для нахождения площади трапеции. 2. Составить программу для нахождения квадрата суммы двух чисел (по формулам сокращённого умножения). 3.
Ответы (1)
Создайте программы на языке PascalABC: 1) Введите два числа (например A=5 и В=8) и найдите их произведение, используя цикл с постусловием и только операцию сложения.
Ответы (1)
Автомат получает на вход нечётное число X. По этому числу строится трёхзначное число Y по следующим правилам. 1. Первая цифра числа Y (разряд сотен) - остаток от деления X на 4. 2. Вторая цифра числа Y (разряд десятков) - остаток от деления X на 3.
Ответы (1)
Составьте программу нахождения суммы всех четных чисел от 10 до 100. 1) использовать цикл с предусловием. 2) использовать цикл с постусловием. 3) использовать цикл с параметром.
Ответы (1)
Составить программу, которая находит минимальное натуральное число х, такое, что остаток от деления х на 10 равен 9, остаток от деления х на 9 равен 8, остаток от деления х на 8 равен 7, ... остаток от деления х на 2 равен 1.
Ответы (1)