Задать вопрос
14 апреля, 13:59

Дан текст. подсчитать, сколько раз в тексте встречается симьол "+" и сколько раз-симбол "*". удалить эти символы, сдвинув текст. текст отпечатать.

+4
Ответы (1)
  1. 14 апреля, 15:35
    0
    Var

    s: string;

    i, n1, n2: integer;

    begin

    writeln ('Введите текст') ;

    readln (s) ;

    n1 : = 0;

    n2 : = 0;

    for i : = 1 to length (s) do

    case s[i] of

    '+': n1 : = n1 + 1;

    '*': n2 : = n2 + 1;

    else write (s[i])

    end;

    writeln;

    writeln (' + удалено ', n1, ', * удалено ', n2)

    end.

    Тестовое решение:

    Введите текст

    Y:=35.45*x+2*y / (z-4) ;

    Y:=35.45x2y / (z-4) ;

    + удалено 1, * удалено 2
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Дан текст. подсчитать, сколько раз в тексте встречается симьол "+" и сколько раз-симбол "*". удалить эти символы, сдвинув текст. текст ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Дано число 7623879554768. В нем удалить восемь цифр, сдвинув оставшиеся, вместе и не меняя их порядок следования. Какое минимальное нечетное число можно получить таким образом из исходного числа?
Ответы (1)
Дана строка. Удвоить каждый символ строки, выбрать из нее символы кратные 4 и напечатать её наоборот. Поясняю, символы кратные 4-ем, это значит каждый 4-ый символ строки. "выбрать из нее символы кратные 4 и напечатать их (т. е.
Ответы (1)
1) Как вставить пропущенный символ в тексте? 2) Как заменить неправильный символ в тексте? 3) Как удалить лишний символ в тексте? 4) Как разрезать абзац на два? 5) Как соединить два абзаца в один? 6) Как вставить пустую строку в текст?
Ответы (1)
Составьте программу, которая позволяет удалить символы t из строки s. Строка s и символ t, который надо удалить, вводятся с клавиатуры
Ответы (1)
Удалить из строки все символы "S" стоящие как после ".", так и после "; ", подсчитать общее количество символов "А" и "B"
Ответы (1)