Задать вопрос
27 октября, 12:39

Заданы 2 одномерных массива. Сформировать третий из элементов с нечетными индексами обоих массивов и положительных элементов второго массива

+5
Ответы (1)
  1. 27 октября, 15:20
    0
    Const n=5;

    var

    i, q:integer;

    a:array [1 ... n] of integer;

    b:array [1 ... n] of integer;

    c:array [1 ... 50] of integer;

    begin

    writeln ('Заполните первый массив') ;

    for i:=1 to n do

    read (a[i]) ;

    writeln ('Заполните второй массив') ;

    for i:=1 to n do

    read (b[i]) ;

    for i:=1 to n do begin

    if i mod 20

    then begin q:=q+1;

    c[q]:=a[i];

    q:=q+1;

    c[q]:=b[i];

    end;

    end;

    for i:=1 to n do

    if b[i]>0

    then begin

    q:=q+1;

    c[q]:=b[i];

    end;

    if q=0

    then writeln ('условие не выполняется')

    else begin

    for i:=1 to q do

    write (' ', c[i]) ;

    end

    end.

    P. s. Вы можете изменять константу, и ограничивать вводимые значения вводом, но не забывайте, что первые два массива не должны превышать количество ячеек, ограниченной константой. Можно эту константу поменять, это все на ваше усмотрение.

    P. p. s. Программа написана на Pascal ABC.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Заданы 2 одномерных массива. Сформировать третий из элементов с нечетными индексами обоих массивов и положительных элементов второго массива ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
1. Даны два одномерных массива разной размерности. Для каждого из заданных одномерных массивов выполнить: последовательно переписать в другой массив отрицательные элементы начального массива. с применение подпрограмм и процедур желательно
Ответы (1)
Даны два одномерных массива разной размерности. Для каждого из заданных одномерных массивов выполнить преобразование массива так: все его элементы, большие девяти заменить числом девять, все его элементы, меньшие пяти заменить числом пять, а все
Ответы (1)
1. Составить программу вывода на экран в первую строку 5 элементов массива, а во вторую - остальные 5 элементов массива; 2. Составить программу вывода элементов массива в обратном порядке; 3.
Ответы (1)
Даны три одномерных массива из целых чисел одинаковой длины. Сформировать четвертый массив, каждый элемент которого равен максимальному из соответсвующих элементов первых трех массивов.
Ответы (1)
1. Возвести в квадрат все элементы массива A. Размер массива и значения элементов массива - произвольные. 2. Увеличить на 4 все элементы в первой половине массива A (считать, что в массиве чётное число элементов).
Ответы (1)