Задать вопрос
23 мая, 16:59

Вариант 1. Задана матрица вещественных чисел размерности m*n. Не используя вспомогательного массива, транспонировать данную матрицу. Размерность матрицы и значения ее элементов ввести с клавиатуры.

+5
Ответы (1)
  1. 23 мая, 19:39
    0
    Var

    a: array[,] of integer;

    i, j, t, n, m, k: integer;

    begin

    write ('Введите размерность матрицы m и n: ') ;

    readln (m, n) ;

    if n>m then k:=n else k:=m;

    setlength (a, k+1, k+1) ;

    writeln ('Вводите элементы матрицы по одному: ') ;

    for i : = 1 to m do

    for j:=1 to n do

    readln (a[i, j]) ;

    for i:=1 to k do

    for j:=i to k do

    begin

    t:=a[i, j];

    a[i, j]:=a[j, i];

    a[j, i]:=t;

    end;

    writeln;

    writeln ('Транспонированная матрица: ') ;

    for i : = 1 to n do

    begin

    for j:=1 to m do

    write (a[i, j]:4) ;

    writeln;

    end;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Вариант 1. Задана матрица вещественных чисел размерности m*n. Не используя вспомогательного массива, транспонировать данную матрицу. ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Задана матрица (двумерный массив) A размером N x М, состоящая из действительных элементов. Числа M и N вводятся с клавиатуры. Для задания исходной матрицы предусмотреть ввод с клавиатуры или ввод с помощью датчика случайных чисел.
Ответы (1)
1) Найти сумму отрицательных элементов массива целых чисел. Размерность массива 10. Заполнение массива осуществить случайными числами от - 20 до 20. 2) Найдите сумму чётных элементов массива целых чисел. Размерность массива 20.
Ответы (1)
1. Возвести в квадрат все элементы массива A. Размер массива и значения элементов массива - произвольные. 2. Увеличить на 4 все элементы в первой половине массива A (считать, что в массиве чётное число элементов).
Ответы (1)
Составить программу на языке Паскаль: 1) Для массива K из 12 вещественных чисел определить сколько элементов массива меньше 0. 2) В массиве М из 10 целых чисел найти количество элементов равных 3.
Ответы (1)
Помогите решить задачи на паскаль. 1) Дан массив случайных чисел (количество элементов вводите с клавиатуры). Найти произведение всех элементов массива. 2) Дан массив случайных чисел (количество элементов вводите с клавиатуры).
Ответы (1)