Задать вопрос
14 августа, 18:19

Сделать проверку упорядоченности элементов одномерного массива по убыванию их значений.

+3
Ответы (2)
  1. 14 августа, 18:43
    0
    Уж сколько раз твердили миру ... чтобы языки указывали._. Ну, ниже представлен пример для PascalABC

    var

    a: array of integer : = (9, 8, 7, 6, 7, 4, 3, 2, 1, 0) ;

    i: byte;

    b: boolean : = true;

    begin

    for i : = 1 to length (a) - 1 do

    if (a[i] > a[i-1]) then

    b : = false;

    writeln (b) ;

    end.
  2. 14 августа, 21:51
    0
    Const

    n = 10;

    var

    a: array[1 ... n] of integer : = (1, 2, 3, 6, 4, 5, 9, 7, 8, 10) ;

    i: integer;

    begin

    i : = 0;

    repeat

    i : = i + 1

    until (i = n) or (a[i] > a[i + 1]) ;

    if a[i] > a[i + 1] then

    Writeln ('Нарушение на элементах ', i, ',', i + 1, ': ', a[i], '>', a[i + 1])

    end.

    Тестовое решение:

    Нарушение на элементах 4,5: 6>4
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Сделать проверку упорядоченности элементов одномерного массива по убыванию их значений. ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Сделать программу в Pascal. 1. Организуйте ввод и вывод одномерного массива в строку, в столбец. 2. Найдите произведение ненулевых элементов одномерного массива. 3.
Ответы (1)
1. Возвести в квадрат все элементы массива A. Размер массива и значения элементов массива - произвольные. 2. Увеличить на 4 все элементы в первой половине массива A (считать, что в массиве чётное число элементов).
Ответы (1)
Написать программу, позволяющую для заданного одномерного массива А из n вещественных или целых элементов реализовать обработку массива. Длина массива N задается пользователем как константное выражение.
Ответы (1)
В записи m[7]=9 m обозначает 1) имя массива 2) имя элемента массива 3) номер элемента массива 4) значение элемента массива в записи m[7]=
Ответы (1)
1) Заполнить и вывести на экран массив 5 х 10 случайных целых чисел в диапазоне от 1 до 10. 2) Найти сумму элементов одномерного массива с k1-го по k2-ой, где k1 и k2 вводятся с клавиатуры. Сделать проверку корректности их ввода.
Ответы (1)