Задать вопрос
22 ноября, 06:12

Пусть задана последовательность чисел a, b, c, d. Составить программу вычисления количества K положительных чисел, содержащихся в

этой последовательности. Печатать a, b, c, d, K.

+5
Ответы (1)
  1. 22 ноября, 08:04
    0
    Var

    a, b, c, d, K:integer;

    begin

    write ('Введите a, b, c, d: ') ;

    readln (a, b, c, d) ;

    K:=0;

    if a>0 then K:=K+1;

    if b>0 then K:=K+1;

    if c>0 then K:=K+1;

    if d>0 then K:=K+1;

    writeln (a,' ', b,' ', c,' ', d,' K=', K) ;

    end.

    Тестовое решение:

    Введите a, b, c, d: - 4 5 3 0

    -4 5 3 0 K=2
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Пусть задана последовательность чисел a, b, c, d. Составить программу вычисления количества K положительных чисел, содержащихся в этой ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
1) Составьте программу вычисления сумму чисел от 1 до 100. 2) Составьте программу вычисления произведения чётных чисел от 1 до 10. 3) Составьте программу вычисления количества двухзначных нечётных чисел.
Ответы (1)
Составить программу: 1. Дана последовательность чисел. Найти количество отрицательных элементов. Последовательность целых чисел Найти сумму между максимальными и минимальным элементом последовательность 0-признак конца ведения последовательности. 2.
Ответы (1)
1. Напишите программу, которая в последовательности натуральных чисел определяет количество чисел, кратных 4. Программа получает на вход количество чисел в последовательности, а затем сами числа. В последовательности всегда имеется число, кратное 4.
Ответы (1)
Дана последовательность чисел, вводимых с клавиатуры и оканчивающаяся нулем. Составьте программу вычисления: a. суммы всех чисел последовательности; b. среднего арифметического всех чисел последовательности: c.
Ответы (1)
1. Напишите программу вычисления расстояния между двумя точками плоскости. 2. Напишите программу вычисления площади боковой поверхности куба. 3. Напишите программу вычисления площади и гипотенузы прямого треугольника, если известны его катеты. 4.
Ответы (1)