Задать вопрос
8 сентября, 07:40

Составить программу на паскаль.

Слова могут содержать любые символы языка. Найти и вывести в самом длинномслове все символы, отличные от заглавных латинских букв. Использовать множества.

+4
Ответы (1)
  1. 8 сентября, 09:01
    0
    var

    a : array of string;

    str, m: string;

    begin

    readln (str) ;

    a : = str. Split (' ') ;

    foreach str in a do

    if (m. Length < str. Length) then

    m : = str;

    foreach kchr: char in m do

    if not (kchr in ['A' ... 'Z']) then

    write (kchr) ;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Составить программу на паскаль. Слова могут содержать любые символы языка. Найти и вывести в самом длинномслове все символы, отличные от ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Ввести слово и число раз (Ввод; паскаль, 3). Вывести это слово так: паскаль паскаль паскаль паскаль паскаль паскаль
Ответы (1)
Для передачи секретного сообщения используется код состоящий из заглавных латинских букв и цифр. При этом все символы кодируются одним и тем же количеством бит. Определите информационный объём сообщения длинной в 180 символов.
Ответы (1)
Помгите! Программа Паскаль Вопрос 1. Функция служебного слова Var. Вопрос 2. С какими числами можно работать в программе Паскаль? Вопрос 3. Оператор ввода. Как он записывается в Паскаль? Вопрос 4. Функция служебного слова Const. Вопрос 5.
Ответы (1)
Автомобильный номер состоит из 8 символов: четырёх цифр, за которыми следуют 4 буквы. Допустимыми символами считаются 10 цифр и 25 заглавных латинских букв (кроме буквы O).
Ответы (1)
Пусть есть высказывание А есть: "Множество А есть подмножество множества В ", высказывание В есть: "Все элементы множества А являются элементами множества В".
Ответы (1)