Задать вопрос
5 февраля, 14:04

Найти сумму всех целых трехзначных чисел которые делятся на 3 и 9 или оканчиваются 5

+2
Ответы (1)
  1. 5 февраля, 15:50
    0
    Var

    i, s: longint;

    begin

    s : = 0;

    for i : = 100 to 999 do

    if (i mod 9 = 0) or (i mod 100 = 5) then s : = s + i;

    {Если число делится на 9, то оно делится и на 3}

    Writeln ('Сумма равна ', s)

    end.

    Результат выполнения программы:

    Сумма равна 59490
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Найти сумму всех целых трехзначных чисел которые делятся на 3 и 9 или оканчиваются 5 ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
1. Даны два целых числа A и B (A < B). Найти сумму всех чисел от A до B включительно. 2. Даны два целых числа A и B (A 0). Найти произведение всех чисел от A до B включительно. 3. Дан массив целых чисел Х. Найти сумму квадратов всех чисел. 4.
Ответы (1)
Найти: а) сумму всех целых чисел от 100 до 500; б) сумму всех целых чисел от a до 500 (значение a вводится с клавиатуры; a 500) ; в) сумму всех целых чисел от - 10 до b (значение b вводится с клавиатуры; b - 10) ;
Ответы (1)
Из ряда натуральных чисел от 1 до 2000 вычеркнули все числа, которые делятся на 2, затем все числа, которые делятся на 3, затем все числа, которые делятся на 5, а затем все числа, которые делятся на 7. Сколько чисел осталось?
Ответы (1)
Из ряда натуральных чисел от 1 до 1500 вычеркнули все числа, которые делятся на 2, затем все числа, которые делятся на 3, затем все числа, которые делятся на 5, а затем все числа, которые делятся на 7. Сколько чисел осталось?
Ответы (1)
С клавиатуры вводится десять целых чисел (до100), найти произведение тех из них которые делятся на три или которые оканчиваются тройкой
Ответы (1)