Задать вопрос
1 июня, 22:48

Найти произведение всех элементов двумерного массива, больших заданного числа

+5
Ответы (1)
  1. 2 июня, 01:50
    0
    Язык какой?

    Паскаль

    type massive=array[1 ... 10,1 ... 10] of integer;

    var m:massive;

    pr:real;

    digit:integer;

    i, k:byte;

    flag:boolean;

    begin

    for i:=1 to 10 do

    for k:=1 to 10 do

    readln (m[i, k]) ; / / заполнение массива

    writeln ('Введите границу: ') ;

    readln (digit) ;

    pr:=1;

    flag:=false;

    for i:=1 to 10 do

    for k:=1 to 10 do

    if m[i, k]>digit then

    begin

    pr:=pr*m[i, k]; / / все, что больше заданного перемножаем

    flag:=true;

    end;

    if flag=false then writeln ('Чисел больше заданного нет.')

    else writeln ('Общее произведение: ', pr:1:0) ;

    END.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Найти произведение всех элементов двумерного массива, больших заданного числа ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
1. Возвести в квадрат все элементы массива A. Размер массива и значения элементов массива - произвольные. 2. Увеличить на 4 все элементы в первой половине массива A (считать, что в массиве чётное число элементов).
Ответы (1)
В записи m[7]=9 m обозначает 1) имя массива 2) имя элемента массива 3) номер элемента массива 4) значение элемента массива в записи m[7]=
Ответы (1)
Паскаль, составьте программу для двумерного массива: Найти произведение отрицательных элементов указанной строки двумерного массива размером 4*5 целых чисел.
Ответы (1)
Написать программу, позволяющую для заданного одномерного массива А из n вещественных или целых элементов реализовать обработку массива. Длина массива N задается пользователем как константное выражение.
Ответы (1)
Построить из элементов двумерного массива одномерный массив, элементом которого являетются четные элементы двумерного массива
Ответы (1)