Задать вопрос
17 августа, 03:35

Трехзначное число, записанное в шестнадцатеричной системе счисления, увеличива-ется вдвое от перестановки первой цифры в конец числа. Определите максимальное из таких чисел, записанное в системе счисления по основанию 16.

+1
Ответы (1)
  1. 17 августа, 04:03
    0
    Var

    i, j, k, ix, jx, kx:integer;

    s:string;

    function per (x:integer) : string;

    begin

    case x of

    10: result:='A';

    11: result:='B';

    12: result:='C';

    13: result:='D';

    14: result:='E';

    15: result:='F';

    else

    str (x, result) ;

    end;

    end;

    begin

    for i:=1 to 15 do

    for j:=0 to 15 do

    for k:=0 to 15 do

    if 2 * (i*16*16+j*16+k) = j*16*16+k*16+i then

    begin

    ix:=i;

    jx:=j;

    kx:=k;

    end;

    s:=per (ix) + per (jx) + per (kx) ;

    writeln (s) ;

    end.

    В результате работы программы получаем ответ.

    Ответ: 6DB
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Трехзначное число, записанное в шестнадцатеричной системе счисления, увеличива-ется вдвое от перестановки первой цифры в конец числа. ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
1) Десятичное число 4563 в двоичной системе счисления равно 2) Десятичное число 800 в восьмеричной системе счисления равно 3) Десятичное число 781 в шестнадцатеричной системе счисления равно 4) Двоичное число 1000000 в десятичной системе счисления
Ответы (1)
1. Запишите число 156 в шестнадцатеричной системе счисления. 2. Запишите число AD16 В десятичной системе счисления. 3. Запишите число 111100000012 в шестнадцатеричной системе счисления. 4. Запишите число 125 В 16 В двоичной системе счисления. 5.
Ответы (1)
А) 1000001110 в двоичной системе счисления+1100110 в двоичной системе счисления б) 10001001 в двоичной системе счисления-1010101 в двоичной системе счисления в) 45 в восьмеричной системе счисления * 71 в восьмеричной системе счисления г) 1AF1 в
Ответы (1)
1. Выполните сложение в двоичной системе счисления: 101112 + 1011102 Результат запишите в двоичной системе счисления. 2. Выполните сложение в двоичной системе счисления: 11012 + 110112 Запишите ответ в двоичной системе счисления.
Ответы (1)
Выполните сложение: а) 1153 в 8 системе счисления + 1147 в 8 системе счисления. б) 4DFв 16 системе счисления + 160 в 16 системе счисления. в) 1110101010 в 2 системе счисления + 10111001 в 2 системе счисления.
Ответы (1)