Задать вопрос
4 января, 18:21

Работница теплицы готовит раствор для подкормки растений. В ее распоряжении имеются стеклянные банки 1, 2, и 3 литра. Какое наименьшее количество банок воды потребуется для подготовки N (N<100) литров раствора?

Пример:

Входные данные = 10

Выходные данные = 3 3 3 1

+1
Ответы (1)
  1. 4 января, 21:53
    0
    var

    x, y: byte;

    begin

    readln (x) ;

    repeat

    if (x div 3 > 0) then

    begin

    write (3:2) ;

    x - = 3;

    end

    else

    if (x div 2 > 0) then

    begin

    write (2:2) ;

    x - = 2;

    end

    else

    if (x > 0) then

    begin

    write (1:2) ;

    x - = 1;

    end;

    until (x = 0) ;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Работница теплицы готовит раствор для подкормки растений. В ее распоряжении имеются стеклянные банки 1, 2, и 3 литра. Какое наименьшее ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Плата за обучение в некоторой автошколе зависит от категории подготовки и наполняемости групп для теоретических занятий. При подготовке на категорию B курсант платит за курс обучения 15 000 р.
Ответы (1)
Для марш-броска по пустыне путешественнику необходимо иметь 4 литра воды. Больше он взять не может. На базе, где имеется источник воды, выдают только 5 литровые фляги, а также имеются 3-литровые банки.
Ответы (1)
Какое наименьшое число переливания потребуется, для того 4 литра кастрюлю с помощью крана и 5 литров банки налить 3 литра воды
Ответы (1)
Как отмерить 3 л, имея сосуд 5 л. Какое наименьшее число переливаний потребуется для того чтобы в 4 литровую кастрюлю с помощью крана и 5 литровой банки налить 3 литра воды?
Ответы (1)
Имеются четырехлитровая банка сока и две пустых банки: двух - и трехлитровая. Как налить в каждую из пустых банок по 2 литра сока?
Ответы (2)